1080p AVI MPEG4 Video plays through SMB but not USB

Home Forums General Discussion 1080p AVI MPEG4 Video plays through SMB but not USB

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #23616

    Today I was browsing the media I have on my PC on WiiMC, through a Samba share. Although I knew WiiMC doesn’t play HD video files, I decided to take a look at what would happen if I selected a 1080p file to play over the network.

    The 1080p video I selected is the Big Buck Bunny open movie project, and thus, it is downloadable for free on the internet if you want to try this out with your Wii (it’s a 885,6MB AVI file). My surprise comes when, from nothing, WiiMC starts playing the video, scaling down from 1080p! I’m sure my PC is not doing any scaling, like VLCShares do.

    The video plays seamlessly the first seconds of video (10, 15 seconds, if changes form time to time), with audio and NO visible framedropping (I have the setting put to “Auto”). After some time, it starts buffering: I’m yet to understand if it’s because my network’s (or the Wii’s wifi) too slow to handle a Full HD stream, or if it’s because mplayer takes too much time to decode the images and then if is always buffering.

    It is quick to buffer entirely: just 6 seconds from 0% to 100%. Just letting it buffer when it needs, I can play the whole video, and I manage to get around 30 seconds of continuous playback. Results are better if you take the cursor out of the screen (drawing the controls takes too much CPU, perhaps?), if you put the cursor in sometimes the image loses quality and it starts buffering often.

    When I play the same file from a USB pendisk, it simply refuses to play. Perhaps it’s because it has quicker access to the file and performs the check to see if the resolution of the video is too high? If such check exists, it would be good to have a setting to override it, at least, to let people experiment a bit. Letting me play from the USB would clarify if the frequent buffering is because of the network being slow, or because of the video being too heavy for the Wii.

    Perhaps the developers can enlighten me? 😀


    What is the error message that Wiimc displays when trying to open the file?

    I do not think there’s some sort of restriction. Whenever I tried different formats and resolutions recommended the Wiimc always tried to display. The most that happened was a drop in frame rate or crash. Maybe your USB flash drive is actually 1.1? Other videos usually run via usb?

    But it is surprising that the Wii can do 1080p downscaling. You can provide the link to this video? I want to try as well.


    I downloaded the MP4 file, but running through the SMB WiiMC was often in ‘buffering’. Maybe my router can not reach full speed (54MB / s), so the buffering happens. USB did not work out.

    But the 720p file ran flawlessly, both via SMB when USB. Even that’s amazing.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.


Lost Password