Build Under Windows

Home Forums Development Build Under Windows

This topic contains 36 replies, has 12 voices, and was last updated by  jhb50 3 months, 2 weeks ago.

Viewing 15 posts - 16 through 30 (of 36 total)
  • Author
    Posts
  • #25330

    Pixel-Kakashi
    Participant

    thanks. I followed pistas instructions and it seems to do the trick. Compiling fribidi worked fine but Iam getting another error wenn compiling libiconv.

    #25331

    BigBolt
    Participant

    @schmidex wrote:

    Anyone else getting this error?:

    Any idea how to solve this?

    Schmindex, are you using the last version of devkit pro? Is it installed properly? Try uninstalling and reinstalling + restarting windows to make sure that windows environment variables are reloaded . Msys does not need any tricks if devkit pro was installed properly.

    #25332

    rodries
    Keymaster

    You’re also missing –disable-shared at the end of that configure line.

    #25333

    Pixel-Kakashi
    Participant

    I uninstalled and restarted. Installed devkitpro again and restarted. Still getting the same error about “no acceptable C Compiler in $PATH” when running the configure command (I also added “–disable-shared”). After modifying the configuration files of MSys this error is gone and configuration seems to work fine. But iam still having the error “…can’t reserve space for cygwin’s heap…” when running “make”.

    #25334

    rodries
    Keymaster

    Seriously, something is borked with your environment. I’ve never had to do any modifications to my path, MSys, or anything else.

    #25335

    BigBolt
    Participant

    Try disabling your antivirus. It seems that some antivirus programs (more exactly the heuristical analysis on memory or the search for unknown threats) are causing problems (panda, norman, windows defender/vista etc).

    #25336

    axgarr
    Participant

    I’m using Win 7 x64, with 8 Gb Ram.
    For x86 software I use Sun Virtualbox with 4 virtual winxp instead (in one I’ve disabled firewall and antivirus)…
    In all enviroment I’ve installed Devkit, and in all I had to edit fstab and profile in msys, today I’ve installed Devkit in my laptop with WinXp, and also in this I had to edit the files…
    I don’t know why some windows systems need to change these parameters …
    language, timeformat, settings???

    Important that the user has solved the problem “no acceptable C Compiler in $PATH”

    For the message: “…can’t reserve space for cygwin’s heap…” check if the windows environment variables are loaded…

    #25337

    BigBolt
    Participant

    @pista wrote:

    I don’t know why some windows systems need to change these parameters …

    Devkit pro installer might be the reason.

    For some reason the devkitpro installer does not always add the path to the GCC compiler to the system path. It does add the path for MSYS which is why ‘make’ works.

    from here

    I’ve also modified windows path when trying to compile mplayer ce (because of the same problem, gcc not found)
    So all you have to do is add to your path, the path to devkit gcc and other executables wich is [path to devkitpro]/devkitppc/bin. If you have installed devkitPro in C:/devkitPro, then go to control panel>system>advanced>environment variables>system variables and add the following line to PATH : C:/devkitPro/devkitPPC/bin and restart Windows to make it reload the new PATH

    #25338

    axgarr
    Participant

    @driverx wrote:

    So all you have to do is add to your path, the path to devkit gcc and other executables wich is [path to devkitpro]/devkitppc/bin. If you have installed devkitPro in C:/devkitPro, then go to control panel>system>advanced>environment variables>system variables and add the following line to PATH : C:/devkitPro/devkitPPC/bin and restart Windows to make it reload the new PATH

    Here is the code in system variables when i installed DevKit in my Virtual machine’s


    DEVKITPPC /c/devkitPro/devkitPPC
    DEVKITPRO /c/devkitPro
    Path c:devkitPromsysbin;c:devkitProdevkitppcbin;.....

    All codes inserted by Devkit are OK…
    But msys report these bug’s… I’ve resolved forcing msys…

    I have no problem compiling WiiMC… 😉

    #25339

    Pixel-Kakashi
    Participant

    thx for the help. I compiled using my winXP netbook (took forever but worked). I had to set the path manualy. Finaly no error about cygwin here.

    #25340

    sir West
    Participant

    I’m trying to compile under ubuntu linux and I always receive this 2 errors:

    /opt/devkitpro/devkitPPC/bin/powerpc-eabi-gcc: 1: Syntax error: “(” unexpected

    /opt/devkitpro/devkitPPC/bin/powerpc-eabi-g++: 1: Syntax error: “(” unexpected

    Anyone knows why I receive them?

    Thanks for your help

    #25343

    bedouinvert
    Participant

    hi guys

    I’ve never had any issues with wiimc compilation however recently (recent revisions)I started having this problem:

    This happens at the final stage of compilation wiimc root “make”

    any ideas?

    #25344

    Anonymous

    @burton wrote:

    hi guys

    I’ve never had any issues with wiimc compilation however recently (recent revisions)I started having this problem bipbipbip

    This happens at the final stage of compilation wiimc root “make”

    any ideas?

    use ‘Boxee’ for windows/mac.

    #25342

    bedouinvert
    Participant

    @macuser wrote:

    @burton wrote:

    hi guys

    I’ve never had any issues with wiimc compilation however recently (recent revisions)I started having this problem bipbipbip

    This happens at the final stage of compilation wiimc root “make”

    any ideas?

    use ‘Boxee’ for windows/mac.

    r u mocking me?

    Anyways I think I’m missing mplayerwii. That must be the problem.

    #25346

    axgarr
    Participant

    There are a new lib in SVN (liba52).

    Please use Configure command:


    ./configure --host=powerpc-eabi --prefix="${DEVKITPRO}/portlibs/ppc" --libdir="${DEVKITPRO}/portlibs/ppc/lib" --disable-shared

    make

    and

    make install

Viewing 15 posts - 16 through 30 (of 36 total)

You must be logged in to reply to this topic.