Linux bash script to setup compiling environment

Home Forums Development Linux bash script to setup compiling environment

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #23404

    While the instructions on the development page are useful, they are a little scattered. My solution to this was to write a little script to setup everything for me.

    You will prolly need to run it as root or sudo it too.

    *Added small menu system
    *Removed command switches
    *Will now downloaded packages it can not find locally


    Is it possible to do this in Windows? I’ve tried to keep the Compile Guide current but it is getting beyond me.


    @jhb50 wrote:

    Is it possible to do this in Windows? I’ve tried to keep the Compile Guide current but it is getting beyond me.

    I think it should be, but you would need to use a batch script or maybe even wsh. I don’t have a windows computer to try it out on though. 😛


    I tried this script, it downloaded all the packages and then…

    2011-05-01 22:28:30 (111 KB/s) – “gamecube-examples-20100930.tar.bz2” salvo [765734/765734]

    ./ 67: Syntax error: “}” unexpected

    And if I try to run again:

    root@GabrielUbuntuDesktop:/home/gabriel# sh ./
    ./ 14: function: not found
    ./ 67: Syntax error: “}” unexpected

    Note: I was running as root (notice the # in the shell).

    Any ideas? Removing the } only makes the situation worse, with more errors. I tried setting up the dev environment manually before I discovered this script, and I wasn’t managing to get it compiling, so I tried this.

    Running Ubuntu 10.10 32bit.

    EDIT: Forget it: I was using sh to run the script. I chmod’ed it to 777 and ran it using ./, now seems to work nicely (still running).


    I managed to get the script working, but whenever it tries to compile it seems to complain about a unexpected “(” in filebrowser.cpp. I’m pretty sure the problem is not with that though.
    The configure scripts returns two errors:
    configure: error: in `/home/gabriel/wiimc-read-only/libs/pcre’:
    configure: error: C compiler cannot create executables tells me this when I try to compile:

    The following can be done
    [1] – Setup the compiling environment
    [2] – Complile WiiMC
    [3] – Clean the compiling environment
    [X] – Exit this application
    What do you want to do: 2
    cd source/mplayer; make -f Makefile; cd ../..
    make[1]: Entrando no diretório `/home/gabriel/wiimc-read-only/source/mplayer’
    help/ help/help_mp-en.h UTF-8
    make[1]: execvp: help/ Permissão negada
    make[1]: Saindo do diretório `/home/gabriel/wiimc-read-only/source/mplayer’
    /opt/devkitpro/devkitPPC/bin/powerpc-eabi-g++: 1: Syntax error: “(” unexpected
    make[1]: ** [filebrowser.o] Erro 2
    make: ** [build] Erro 2
    Press [Enter] to continue…

    (where it says “Permissão negada” it means “Permission denied”, “Entrando no diretório” is “Entering directory”, “Saindo do diretório” is “Exiting directory”. This thing of having make output in different languages is very unpractical…)

    I’m not sure if this is related to the script, to WiiMC code, to devkitPPC, or to my system configurations. bookondoklife, in which linux distro did you develop this script? Anyways, when I did not use the script, it also wouldn’t compile, but the error was different (I think I set up it wrong…)…

    Any help is very much appreciated. Is pretty damn bad when you can’t contribute your knowledge and ideas to open source projects… 🙁

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.