Using Samba with SMB shares.

Home Forums Help and Support Using Samba with SMB shares.

  • This topic is empty.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #23800


    I have WiiMC 1.2.0, and I am having difficulty getting it to “talk” to my Linux SMB server. I have a number of other clients, including Windows XP and Windows 7 machines that connect just fine, but the Wii errors out. I turned up logging on the samba server, and nothing really shows up that indicates what the problem is.

    My Samba implemention is using ADS (Active Directory) authentication, is it possible that is the cause of the issues?

    Log from a session included below.

    [2011/11/03 12:56:13, 6] param/loadparm.c:lp_file_list_changed(6625)
    file /usr/local/samba/lib/smb.conf -> /usr/local/samba/lib/smb.conf last mod_time: Thu Nov 3 12:38:59 2011
    [2011/11/03 12:56:13, 3] smbd/oplock.c:init_oplocks(875)
    init_oplocks: initializing messages.
    [2011/11/03 12:56:13, 3] smbd/oplock_linux.c:linux_init_kernel_oplocks(241)
    Linux kernel oplocks enabled
    [2011/11/03 12:56:13, 10] lib/events.c:event_add_timed(128)
    Added timed event “idle_evt(keepalive)”: b8085138
    [2011/11/03 12:56:13, 10] lib/events.c:event_add_timed(128)
    Added timed event “idle_evt(deadtime)”: b80852d8
    [2011/11/03 12:56:13, 10] lib/util_sock.c:read_smb_length_return_keepalive(1118)
    got smb length of 68
    [2011/11/03 12:56:13, 6] smbd/process.c:process_smb(1546)
    got message type 0x81 of len 0x44
    [2011/11/03 12:56:13, 3] smbd/process.c:process_smb(1549)
    Transaction 0 of length 72 (0 toread)
    [2011/11/03 12:56:13, 2] smbd/reply.c:reply_special(425)
    netbios connect: name1=*SMBSERVER name2=SMBCLIENT
    [2011/11/03 12:56:13, 2] smbd/reply.c:reply_special(432)
    netbios connect: local= remote=smbclient, name type = 0

    Has anyone implemented something like this with WiiMC?

    The software looks great, and I am able to get YouTube to play, so I have network connectivity.

    Thanks kindly,


    SAMBA + WiiMC will work, but AD (or domains!) aren’t supported. Here’s what is:

    NTLM v1 authentication over port 445 (ie: no NETBIOS)


    I added port 445 to my Samba setup, and allowed NTLMv1 authentication, and it works like a charm! I can now access all of my media. WiiMC is great! Thanks to everyone who puts in the effort to develop it!


    @Zaph and Tantric:

    Is it really running 100%? Watching 1-2h without any drop? Connected with Wlan I assume? Connected to my Win7 Server it always drops me out somewhen (from 5min to 2h) and i need to restart the wii to reconnect to wlan…


    Mine is running pretty well. I have not tried to watch a full length movie yet, I mainly use the Wii for listening to music whilst in the basement. It is not a platform I would watch movies on when I have other alternatives for that, so I would not be able to comment on video performance.

    In terms of a music player ‘tho, it works really well.



    Works great for me, USB LAN to Windows Server 2008 R2. Never any problems.


    If there’s any chance I can get this to work on my setup I’d love to do so. I’m running a pogoplug with optware and Samba2 installed. I tried finding more information on how to configure the settings mentioned earlier in this post but I’m not having any luck so far. I have access to the samba server from my mac and PC but not on wiimc yet.

    I thought that by having (encrypt passwords = yes) and (smb ports=445) that would do the trick. But I honestly don’t know much about these settings and even how to setup usernames and passwords. I’m trying to access from Wiimc as the root user with the same password I use to SSH to the device.

    Here is my config file: Any advice or ideas are greatly greatly appreciated.

    workgroup = workgroup
    server string = Pogoplug Samba2 Server
    hosts allow = 192. 127. ..# you may need to put 10. here
    null passwords = yes
    guest account = root
    log file = /opt/var/log/samba/log.%m
    max log size = 50
    security = share
    encrypt passwords = yes
    smb passwd file = /opt/etc/samba/smbpasswd
    dns proxy = no
    preserve case = yes
    local master = no
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    smb ports = 445

    comment = black-enclosure
    path = /tmp/.cemnt/mnt_sdb2
    available = yes
    public = yes
    writable = yes
    printable = no
    create mask = 0777
    guest ok = yes
    browseable = yes

    comment = white-enclosure
    path = /tmp/.cemnt/mnt_sda2
    available = yes
    public = yes
    writable = yes
    printable = no
    create mask = 0777
    guest ok = yes
    browseable = yes


    update: I also tried using (client ntlmv2 auth = yes) and (ntlm auth = yes)

    update #2: I ran a testparm on the samba server and here are the results: It’s ignoring the lines I added. I probably didn’t mention that I’m running a Samba2 setup. I wonder if that has anything to do with this.

    -bash-3.2# /opt/bin/testparm
    Load smb config files from /opt/etc/samba/smb.conf
    Unknown parameter encountered: “smb ports”
    Ignoring unknown parameter “smb ports”
    Unknown parameter encountered: “ntlm auth”
    Ignoring unknown parameter “ntlm auth”
    Unknown parameter encountered: “disable netbios”
    Ignoring unknown parameter “disable netbios”
    Processing section “[WD640]”
    Processing section “[Root$]”
    Processing section “[External]”
    Loaded services file OK.


    I’m still looking for any help with this if someone has a little time and more know-how than myself. Happy New Year!!!

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘Help and Support’ is closed to new topics and replies.