VLC Streams won’t open on devices other than host

Home Forums Third Party Enhancements VLC Shares VLC Streams won’t open on devices other than host

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #23950
    fozzums
    Participant

    I love this program, but I’m having some trouble with VLC streaming. The “Watch directly” option on the wii works, and the “Start VLC stream” option does start a stream, but I can’t open that stream on the wii — or on another computer on the network that I used to test it. This is a problem because a lot of the videos I want to watch (notably about 90% of the content on tv-links.eu) are too big for the Wii to handle natively. I can open up a second session of VLC on the host computer and watch the streams through that, but that doesn’t help me get them to my (too old to just hook up via HDMI) TV. I’m not really sure what would cause this; my first guess would be the Windows firewall, but I’ve gone as far as completely turning both it and my virus scanner off without it making a difference. My second guess would be something in the router’s settings, but I doubt that’s the case because I actually managed to get it working for a little bit yesterday without touching the router, but I can’t for the life of me isolate what change I made that made it work, or what broke it again. Any idea what might be causing this?

    P.S.:

    The exact error I get when clicking on “go to stream” in the WiiMC menu is :

    Error

    Error Loading File!

    Edit: Forgot to mention, operating system is Windows 7 X64, WiiMC version has been both 1.2.2 and 1.2.3 (I downloaded the update hoping some of the networking updates would help), and the VLCHosts version is 5.4. I tried the 5.5 alpha, but it didn’t work, either.

    Also, VLC is version 2.0.0., although I’ve tried everything from 1.1.7 forward. 1.1.8 and 1.1.9 both worked temporarily, but it was very temporary — any streams opened up in WiiMC would close after a few seconds. Come to think of it, trying to fix that is what brought it back to not working at all. I tried going back to the versions that worked, but it didn’t help; the stars must have been aligned just right or something.

    #30034
    fozzums
    Participant

    Scratch that, I just completely reinstalled 5.4, went back to 1.9 on VLC, and turned off my firewall. For some reason, doing those individually didn’t fix anything, but doing them all together got it working perfectly. I think I need to see about a third party firewall, because Microsoft’s version doesn’t want to play nice; it had my VNC software blocked, too.

    #30035
    zany130
    Participant

    VLC 2.0 is unsupported from vlc-shares 0.5.4. If you want to use vlc 2.0 you have to move on vlc-shares 0.5.5 alpha2+ and set vlc version to 2.x in vlc-share’s configurations.

    #30036
    fozzums
    Participant

    Thank you. That was one major part of my problem. The other was that Windows Firewall just wasn’t letting the traffic through to the network; I installed commodo, set up my rules, and it’s working now. I am having some problems with tv-links.eu streams all saying “invalid link,” but that could have just as easily been caused by a DMCA takedown or by a change to the way the site works as it could by a problem with my software setup, and considering that Hulu and the like work, I don’t want to mess up what’s working.

    #30037
    zany130
    Participant

    if you give more info about the hoster of the link and a debug log file i can try to figure out the problem. Remember also that the only links that can be watched from tv-links are the ones which have a valid plugin for vlc-shares.

    #30038
    fozzums
    Participant

    Where do I find the debug log file? Or, I guess more appropriately, which one do you need? EasyPHP provides several error logs, but I don’t see anything labeled “debug.” The plugin that is currently sort of working is Gorrillavid. Opening a Gorrillavide link in tv-links leads to the normal “watch directly” and “open with VLC” options, but neither one works; it gives an “error loading file” error, and it seems like the file isn’t there. I can’t even open it on the computer I’m using as a server with VLC. Everything else — putlocker, Filebox, Sockshare, and so on — just gives me an “invalid link” error. All four of those services were working yesterday. The shows and episodes I’ve been testing with have primarily been Star Trek TOS Season 1 episode 5, and Star Wars: The Clone Wars season one episode 6. Both episodes were working from various links yesterday. Oh, and as a control, the Hulu and Southpark plugins are both working normally.

    #30039
    zany130
    Participant

    Filebox is not supported.

    debug log must be enabled in vlc-shares configuration page (and set debug level to all, showing advanced configs). Then you can find debug log file in %TMP% folder.

    #30040
    fozzums
    Participant

    Alright, the log is attached. It shows me successfully using the “watch directly” option, failing with VLC a few times with the firewall both on and off, successfully getting South Park with VLC, and then showing the “invalid link” error on a few non-Gorrillavid services with the firewall off. Thank you for being so helpful.

    #30041
    zany130
    Participant

    Everything looks ok. Some problems about transcoding mode has been solved in 0.5.5. Putlocker/Sockshare problems could be related with server congestion. Don’t think firewall has nothing to do with your problem. Anyway if you want to workaround problems with transcoding mode waiting for new version, you could disable ffmpeg helper in vlc-shares options. If you decide to do it, try and let me know.

    #30042
    fozzums
    Participant

    Thanks for the help. I tried disabling FFMPEG, but it didn’t seem to make a difference; the things that weren’t working still aren’t working. I can wait for 5.5, though; there’s plenty of other video sources in there that do work, including Youtube and Hulu, so I won’t exactly be starved for entertainment. It’ll just be a bit less convenient in the meantime.

    Again, thank you — this is quite possibly /the/ best app I’ve found for wii homebrew, and I mainly use the thing as a media player to begin with.

    #30043
    pregnancysymptoms
    Participant

    got the same problem here,
    went back to wiimc 1.2.0 and it worked fine again.

    #30044
    potnazi
    Participant

    @ximarx wrote:

    VLC 2.0 is unsupported from vlc-shares 0.5.4. If you want to use vlc 2.0 you have to move on vlc-shares 0.5.5 alpha2+ and set vlc version to 2.x in vlc-share’s configurations.

    Thanks for pointing that out – it should really be made clear in the instructions!

    #30045
    marwan330
    Participant

    @ximarx wrote:

    VLC 2.0 IS NOT SUPPORTED WITH VLC SHARES 0.5.4

    This should have been made perfectly clear that you need VLC 1.1.9 to run VLC Shares 0.5.4 ! I just spent a reinstall of Win7 and 4 days debugging VLC Shares before I found this out. BTW, VLC Shares in general is an amazing program.

    #30046
    marwan330
    Participant

    @thedutch wrote:

    got the same problem here,
    went back to wiimc 1.2.0 and it worked fine again.

    Hi Dutch,

    I was wondering, could you post your onlinemedia.xml . Mine is below, but it sucks the big one and will not allow me to view the VLC Stream, but it does a good job of allowing me to click through the videos.

    tstwitters onlinemedia.xml


    <link name="Navi-Xtreme Media Portal" addr="http://navix.turner3d.net/wiilist/&quot; />
    <link name="SHOUTcast Radio" addr="http://www.wiimc.org/media/shoutcast_radio.php&quot; />
    <link name="SHOUTcast Radio – Search" type="search" addr="http://www.wiimc.org/media/shoutcast_radio.php?q=&quot; />
    <link name="SHOUTcast TV" addr="http://www.wiimc.org/media/shoutcast_tv.php&quot; />
    <link name="YouTube" addr="http://www.wiimc.org/media/youtube.php&quot; />
    <link name="YouTube – Search" type="search" addr="http://www.wiimc.org/media/youtube.php?q=&quot; />

    <link name="Radio Plus" addr="http://radioplus.dnsalias.org:8000/listen.pls&quot; />
    <link name="Otvoreni radio" addr="http://82.193.201.234:8001/listen.pls&quot; />
    <link name="Woxy radio" addr="http://woxy.lala.com/stream/aac32.pls&quot; />

    <link name="VLC-Shares Collections" addr="http://192.168.1.4/vlc-shares/&quot; />

    #30047
    bobnabob
    Participant

    Hey ts, if Some of your links are bad.Best thing to do is download a new install of wiimc and swap out onlinemedia files.Then add your VLC link to it somewhere.Your VLC-shares link should look like below.Rule of thumb is if your link refers to playlist then type=”playlist” or if it is a search then type=”search”.Should be one or the other.All links except vlc-shares refer to wiimc and won’t effect vlc-shares.The older versions of vlc had public added to the end of the adress,like the first example.2nd example is for the later versions.
    replace the &quot with “

    addr=”http://xxx.xxx.x.x/vlc-shares/public&quot; />

    <link name="My Vlc-Shares" type="playlist" addr="http://192.168.1.4/vlc-shares&quot; />
    make sure php is listening for 192.168.1.14 or all 0.0.0.0
    also whenever type=”search” This brings up the key board in wiimc for a query.

Viewing 15 posts - 1 through 15 (of 15 total)
  • The forum ‘VLC Shares’ is closed to new topics and replies.