WiiMC 1.2.3 some characters bugged

Home Forums Help and Support WiiMC 1.2.3 some characters bugged

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
  • #23952

    I’m using WiiMC with spanish language and the accented words display strange characters, it didn’t happen in the previous release (1.2.2)



    Can confirm it for German, too.

    All Umlaute (äöü, ÄÖÜ) are displayed(in the settings of WiiMC)
    with the wrong codepade since update from 1.2.2 to 1.2.3 .

    Looks exactly like what happens when you copy windows text files to macintosh
    or vice versa.


    Failure is back


    Yes, i’ve got that problem too, with cyrillic (russian) font.
    Copiin’ under windows (new install?) does not make any change.
    Back on 1.2.2


    It looks like new release (1.2.3) will not work properly with NTFS hard drive, it will work but on english. With another HDD in FAT32 – every strange russian letter looks as usual 😀 😆
    And works fine for me without any HDD, but in moment when i plug into Wii HDD in NTFS – problem appears
    It not depends on version of HomeBrewChannel, tested with 1.0.8 and 1.1.0


    I’m guessing all of this is a build issue with FreeType…

    Golden Avatar

    Hi, Tantric
    I have tested the new version of wiimc these days.

    This issue seems only happen within HDD!!
    (The HDD was formated as FAT partition to put wiimc on it, instead of SD card)

    It is strange !? If wiimc was executed from SD card. It’s normal.
    No characters bug!!

    Back to v1.22, Everything is ok to me.

    Maybe this help!!

    Many many thanks to your program.



    Could you try this beta?


    Golden Avatar

    Hi, I have tested the beta file.
    No luck!!

    1. When there is a directory name with chinese_T in the root of HDD.
    Wiimc can’t be loaded!! It will show an error message :
    “can’t create wiimc on usb1:/apps/wiimc…” something like that.
    The FAT filesystem will be mess up, There will be two “apps” in the root of HDD.
    The HDD must be chkdsk for later use!!

    2. When there is no directory name with chinese_T in the root of HDD.
    Wiimc loaded. char problem is stil there. Nothing changed!!

    I don’t think this is a building problem.
    For the new version of HBC has the similar problem.
    There may be something wrong about libfat.
    (free type or char set problem or … )

    Wiimc and HBC were all ok before (old versions).

    Thanks again.

    I have post the info to hackmii and Marcan has noticed this.
    Hope he can solve the problem.

    (Using 4.3J SM and HBC v1.1.0 right now)

    Golden Avatar

    Hi, Tantric

    I found newer Wiiflow mod since r175 has the similar problem.
    I told to FIX 94.
    He rebuild the wiiflow with the old libfat.(r24)
    The problem is solved.
    I think you should know about this.

    Here is what he told to me :
    First message is
    “I reverted back to devkitppc r24 and compiled the libs with it again, so its no wiiflow problem.”
    Second message is
    “The libogc is still the same, also still compiled with devkitppc r25. So the new motion+ thing works fine.
    I just reverted libfat and the devkitppc version. “

    Hope this helps!!


    Here’s a beta with r24. Let me know how it is.


    Golden Avatar

    I have tested the beta-r24 file.
    The problem is solved.
    So, it must be the libfat’s problem?!

    The font seems different from previous version.
    This version is still v1.2.3 or just beta one?
    Can I mail it to my friends to try ?
    Or wait the next release version ?



    I have tested the “beta with r24” too with german language.

    The character issue seems to be solved,
    but there is now no way to connect to online media with it.


    Is it still solved in this version?


    Golden Avatar

    Yes, it is still solved the char problem!!

    I have tested it with the on-line media function.
    It’s ok, too.

    Also, I have tested some media files which can’t be play smoothly before.
    Some of them can play too.

    This version is much better than ever!!


Viewing 15 posts - 1 through 15 (of 17 total)
  • The forum ‘Help and Support’ is closed to new topics and replies.


Lost Password