BigBolt

Forum Replies Created

Viewing 2 posts - 16 through 17 (of 17 total)
  • Author
    Posts
  • in reply to: linker can’t find -lmplayerwii #24655
    BigBolt
    Participant

    @excelsior wrote:

    just like the title says:

    linking … wiimc.elf
    /home/chris/Desktop/devkitpro/devkitPPC/bin/../lib/gcc/powerpc-eabi/4.4.3/../../../../powerpc-eabi/bin/ld: cannot find -lmplayerwii
    collect2: ld returned 1 exit status

    any suggestions?

    If all went ok libmplayerwii.a should be inside /wiimc/source/mplayer folder.
    Anyway, in the latest version – r205 video playback doesn’t work at all (crash with code dump vhen trying to play movies from usb hdd or from sdd with the usb hdd plugged out.)

    in reply to: Need to deinterlace when playing some videos. #24649
    BigBolt
    Participant

    Mplayer , the videoplayer of Wiimc has some good deinterlace filters (and many others) wich can be added via the command line or .conf file but Tantric has no intention of adding .conf file support and even if you could add the deinterlace filter (yadif, mcdeint, tfields etc), the framerate will drop so much that the movie will turn into an slideshow of images…
    My favourite filter is yadif=1 wich outputs 1 frame for each field resulting 50 fps from a 25 fps interlaced movie. At 50 fps the video playback is very smooth (you can try the filter using windows version of mplayer because wii processor does not have the power to apply the filter in realtime, or it has the power but the code isn’t optimized)
    But since the wii video-output is interlaced there must be a way to play interlaced movies without first deinterlacing and then interlacing them again…

Viewing 2 posts - 16 through 17 (of 17 total)