Crash dumps since the last update – Sample file included

Home Forums Help and Support Crash dumps since the last update – Sample file included

  • This topic is empty.
Viewing 15 posts - 46 through 60 (of 80 total)
  • Author
    Posts
  • #29490
    Anonymous
    Inactive

    Hi I’m having the same trouble here with Wiimc player! Every time i load a youtube video wiimc will crash and give me a reload in 8 seconds. I’ve tried deleting the no ios reload / starting from hbc and using a different forwarding channel on the wii menu to no avail wiimc is still crashing.
    But as mentioned in simlar threads after getting wiimc to play one file from youtube it will then play most at a struggle. I’ve notice as well that wiimc is now not telling you if it can play the video file or not when using youtube.

    I have also used another sd card with only wiimc in the app folder and nothing else and christ doesn’t it load quick it’s like lighting! But this too ends up with wiimc crashing. I’ve tried earlier versions and this too is resulting in crashes.

    But when i use shoutcast tv i believe you call it i can load any file from this and the player will play with no crashes!!! And the same with radio stations this works perfect every time. It seems to be only youtube videos that are given me trouble.

    Hope this helps in sorting out the problem.

    #29491
    hpeviajr
    Participant

    I am also having the same exact issue and I hope this can be fixed because I love WiiMC! Dont get me wrong WiiMC works but it can just be quirky at times for me. Here is my exact situation with details. I use WiiMC 1.2.0 to play videos over SMB over wifi. There are some video files that will play sometimes and then other times they wont. Sometimes just turning the Wii off and on a few times I can finally get them to play other times it wont work until maybe the next day. Sometimes I can get the file to work by simply restarting the the computer (windows XP with an external hard drive shared) that the SMB is located on. Yet I can get other videos to play off the same hard drive without having to restart. Below I am going to post the details of one particular video file that gives me the black screen dump. Here it is:

    Format : AVI
    Format/Info : Audio Video Interleave
    File size : 690 MiB
    Duration : 1h 44mn
    Overall bit rate : 921 Kbps
    Writing library : VirtualDub build 0/release

    Video
    ID : 0
    Format : MPEG-4 Visual
    Codec ID : DIV3
    Codec ID/Hint : DivX 3 Low
    Duration : 1h 44mn
    Bit rate : 756 Kbps
    Width : 640 pixels
    Height : 480 pixels
    Display aspect ratio : 4:3
    Frame rate : 23.976 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Compression mode : Lossy
    Bits/(Pixel*Frame) : 0.103
    Stream size : 566 MiB (82%)

    Audio
    ID : 1
    Format : MPEG Audio
    Format version : Version 1
    Format profile : Layer 3
    Codec ID : 55
    Codec ID/Hint : MP3
    Duration : 1h 44mn
    Bit rate mode : Constant
    Bit rate : 32.0 Kbps
    Channel(s) : 2 channels
    Sampling rate : 48.0 KHz
    Compression mode : Lossy
    Stream size : 114 MiB (17%)
    Alignment : Aligned on interleaves
    Interleave, duration : 24 ms (0.58 video frame)
    Interleave, preload duration : 100 ms
    Writing library : LAME3.88 (alpha 1)

    Hopefully this is of some help in possibly correcting the problem. I will also post more details as I get time. I will try changing no_ios_reload line from the meta.xml as Tantric suggested to someone else. I will post my results of this. I will post a sample of one of the videos I am having issues with as well. If there is anything at all I can do to help figure out what is causing this issue and get it resolved let me know. Thanks.

    #29492
    hpeviajr
    Participant

    Had a whole new issue today I have never had before unrelated to the dumps on playing a video file. Today WiiMC was stuck on the loading screen when trying to play a video. It would stay stuck on the loading screen for over 5 minutes. It did this on 2 different SMB sources. One on my Windows XP laptop and another on a hard drive I have connected directly to the USB on my router. I had no problem streaming the videos to my other laptop using VLC player and also to my Patroit Box Office media player via wifi so this is not a network issue. I even totally restarted my router and still got the same result from WiiMC. All videos would do this to nothing would load at all. I finally got it working by cycling the wii off and on about 7 or 8 times dont know if that even had anything to do with it. Anyway I will post more details about the crash dumps issue as I can.

    Forgot to mention I had no problem streaming video to the wii using Mplayer CE but they would not load in WiiMC.

    #29493
    Shnazzyone
    Participant

    Easy Fix for crashing WiiMC:

    If you have problems with your videofiles(on FAT or NTFS) try this first:

    1) Connect your HDD to Windows and let a chkdisk run.

    Open Windows Command Line: Win+R > cmd > RETURN(Enter)
    chkdsk HDD: /F /V

    Example: chksk e: /F /V /X

    2) After this defrag your HDD(don’t defrag SSDs or USB-Sticks !)

    You can use the free Piriform Defraggler: http://www.piriform.com/defraggler/download/slim

    After this WiiMC is mostly happy and plays your video files.

    #29494
    jamied486
    Participant

    OK, I know I’m tempting fate here, but before I do, I’ll just start by thanking Tantric and everyone else for a great product. As a developer with software of my own out there that isn’t perfect, I know how frustrating it can be when something works fine under your own tests, and then people using it have problems.

    After my last post on this topic where I basically indicated that I was having the same problems as everyone else, I reverted my installation back to 1.1.8 which works a treat.

    Having come back here today to see if anything has changed I’m amazed that there are still heaps of people here having the problem and yet no solution…

    The straw clutching, blaming fragmented drives, bad SD cards, etc all seem like a lot of guesswork to me. From what I can see, it doesn’t matter where the video comes from, or it’s format, the software is flaky. Something MUST have changed in the 1.1.8 to 1.2.0 update that has caused this problem.

    Tantric, are you running the exact same binary, or a local build from the same code? Is it possible that the public binary has some minor corruption in it? Can you rebuild 1.20 and check to see if it matches?

    The way this problem happens only on first play of a video smacks of an initialisation issue to me. Are we dealing with some uninitialised data within the application that on one run is OK, but on 4 out of 5 causes a crash?

    Were the changes in code between 1.1.8 and 1.2.0 dramatic? It is worth doing a diff of the two sets of code, or would that be unrealistic?

    I know I’m probably asking questions that have been asked before, or making suggestions that have been checked already. I’m not trying to teach anyone how to suck eggs, and I don’t mean to sound like a know-all. I’m just trying to sound out a few thoughts in case one of them hits the mark, especially for people like Tantric or jhb50 who have done so much.

    Again, thanks for a great product. My family uses it almost daily, and apart from the nag to update, it works almost flawlessly under v1.1.8.

    #29495
    cadbusca
    Participant

    I’m inclined to agree that the binary is flakey. I use the same SVN9995 source as 1.2 release, and have done nothing to fix any bugs in the base code, yet my compiles, which I have done repetitively in making the modeifications to support a new WIIMC JUKEBOX feature, all work without any problems. The major change in 1.2 was the use of updated prereq libraries, so perhaps my versions are slightly different than those used for the official release. My point though is that I see nothing the matter with the WIIMC code (except a small bug in http which I have reported but should not cause any crashes). I’d suggest others who have made their own compiles, post their findings.

    #29496
    rodries
    Keymaster

    I really have no ideas or time to debug it right now. jhb50’s suggestion sounds good.

    #29497
    tlefdndej
    Participant

    I want to report that wiimc crashes/dumps on me when it tries to play ANY youtube video, no matter what size or quality it is.

    #29498
    hidude
    Participant

    Hi Im getting the crash dumps striaght away

    bit of history

    I used this method for softmodding the WII via letterbomb
    http://www.wiihacks.com/recommended-faqs-guides-tutorials-only/96886-guide-softmod-any-wii.html

    Then i came striaght here downloaded WiiMC Channel Installer 1.9 and WiiMC 1.2.0 (New Install)

    The channel installer crashes instantly and WiiMC 1.2.0 got me to the choose which media format page i chose DVD
    and then got a crash dump, 1.1.7 does the same but crashed after a few seconds at the `choose which media
    format`page while i was doing nothing and no media was in the drive…. basicly it crashed itself.

    It seems this type of program at the minute needs a self diagnostic before use, as in files present and if a disc or media format is readable before playing, it maybe to do with different versions of hardware within the WII???
    or codecs not being liked by a version of a chip in the WII

    All i needed the program to do is read a general DVD-R vobs file backup…..

    Maybe you could breakup the program to be a disc player or a compressed media format player possibly to narrow things down…

    Update.

    I`ve just tried MPlayer CE version v0.80 r658 (04.03.2011) and it played the DVD with no crash or problem straight away, does what i want hope this program can sort out the crashes.

    #29499
    viper610
    Participant

    I’m getting crash dumps too.

    The crash dumps themselves (DSI or ISI, I have seen both). Have not responded to any of the workarounds posted here, and I’ve tried them all. FWIW, I load all video from an FTP share, and my Wii gets a files through wireless router (and the Wii is the only wireless device accessing router).

    Is there someone with a bit of programming knowledge who might be able to identify a root cause based on the stack dumps? Those Fatal Exceptions Windows is famous for are actually quite helpful, this should be no different. I have a sneaking suspicion that the answer might be somewhere in the Write command or something like that. The Settings.xml corruption and now this, seem to me to behave as if there is an issue creating a file, possibly deleting a same-named temp file used for caching… or something like that. Where are the cached files created?

    I’m just brainstorming here…. throwing out ideas. I think many of us realize how good this player is ( compared to the other offerings ), and we’re interested in helping provide information that leads to a solution.

    The more information presented, the more likely a root cause will come to light.

    S~

    #29500
    Pryce
    Participant

    Ok, now y deleted whole SD card, and installed from scratch.

    I have noticed, crashes has reduced to 0… but starting WiiMC from Homebrew.

    I am quite sure now the problem is in wiimc channel. I start the channel, wiimc crashes most of the times. I start homebrew, then wiimc… almost never crashes.

    Hope this helps, Tantric (and to all the people with crashes.. just use homebrew to launch 1.2.0).

    #29501
    Drew Buglione
    Participant

    Any chance a new version could be released to see if we can get anything fixed?

    If not, does anyone have any recommendations for any alternative programs I can use to play my videos? Having to play a movie 19 times to get it to work is getting really old… Especially since it’s been 4 months.

    #29502
    lowell
    Participant

    Well, I’m still on WiiMC 1.1.4 (see downloads section to find it); every newer version just randomly crashes, no matter if I’m just browsing my Harddisk or visiting the settings or watch a movie file. And I can’t even reproduce that behaviour (and I tried literraly everything possible to make a newer version work).

    But 1.1.4 is fine and any REALLY new feature isn’t in the newer releases – so it’s ok. But nontheless it’s damn strange. That’s my two cents, hope that may help someone – and happy holidays. 🙂

    #29503
    VashTS
    Participant

    Heres this beta file: http://www.wiimc.org/files/wiimc-1006-beta.zip
    Working fine here finally. Kudos to the devs!

    #29504
    Drew Buglione
    Participant

    Just got an update prompt and installed it. First movie I tried to play worked so that’s a good sign.

    Hopefully the rest keep working.

    Thanks for the update!!

Viewing 15 posts - 46 through 60 (of 80 total)
  • The forum ‘Help and Support’ is closed to new topics and replies.