Watch Megavideo,HD,Youtube w/ CC through WiiMC (VLCShares)

Home Forums Third Party Enhancements VLC Shares Watch Megavideo,HD,Youtube w/ CC through WiiMC (VLCShares)

Viewing 15 posts - 196 through 210 (of 220 total)
  • Author
  • #26466

    Unfortunately I can not add correctly Dashboard
    Online Library New RTMP stream and Create a plugin for You can ask the priv to detail or tutorial. After my attempts to load an error pops up with stream. Please help


    vlc-shares 0.5.5alpha2 is available for testing:

    *** 0.5.5 alpha 2 (21/02/2012) ***
    – compatibility with vlc 2.0 and 1.2-git
    – improved compatibility with ffmpeg
    – streamer code refractoring
    – improved integration with rtmpdump and sopcast
    – some changes in lvl1 api about stream wakeup and controls
    – threads lib in library
    – streamers lib in library (threads-based)
    – new transcode profile for tegra2 based android devices (h264/mp3 over rtsp)
    – upnp server soc (experimental, not tested)
    – fix in windows installer

    Windows installer:
    Ubuntu 11.10 deb installer:
    Manual installation package:

    Features i’d like to get well tested are all about new profiles/devices compatibility and new vlc/rtmpdump/sopcast startup and management code.


    vlc-shares 0.5.5beta is available for testing:

    *** 0.5.5 beta (05/03/2012) ***
    - Auth plugin is always enabled now. Login can be enabled during installation or from configs page (as configuration)
    - ACL features added
    - Basic rules for core resources
    - ACL helper added: allow basic acl management
    - New ACL fragment in plugin manifest. More info in docs/manifest_plugin.xml
    - New file attributes in files section in plugin manifest:
    * file can be replaced if explicitally required
    * file permissions can be specificed (for linux env)
    * failed file copy can be ignored if specified
    * ... more info in docs/manifest_plugin.xml
    - vlc-shares configuration page merged with plugins configuration
    - new api for form element management
    - core plugins management features moved inside plugin installer controller
    - new repository plugin installation gui (thumbs support)
    - new optional plugin installation gui during installation (thumbs support)
    - guis for acl/permissions management
    - security implemented in HttpPost thread starter
    - getManageIndexLinks for lazy plugins deprecated
    - Webkit renderer is not default gui anymore for webkit devices because it requires lots of bug fixes. It can still manually selected
    - Vlc 2.0 supported
    - Default vlc version setted to 2.0
    - Vlc log can be enabled in configurations

    Windows installer:
    Ubuntu 11.10 deb installer:
    Manual installation package:

    Some screenshots of new features


    vlc-shares 0.5.5beta2 is available for testing:

    *** 0.5.5 beta2 (10/03/2012) ***
    - Automatic category selection when adding a new link from inside a category
    - New bookmarklets:
    * allow to capture manually all kind of links
    * allow to bookmark page
    * crazy-page proof
    - New plugin bookmarks:
    * allow to bookmarks page and get them parsed on the fly for new video links from vlc-shares.
    * Bookmarks added through the new bookmarklet can store authentication cookies for page that requires user login.
    (Google Chrome extension "cookie.txt export MOD" can be used to catch HttpOnly cookies. Downloadable from project site)
    - New Threads Manager GUI:
    * allow to get threads informations and to stop/clear/start them if there are pending jobs
    - Fixed few bugs to transcoding mode startup
    - Fixed a bug in SopCast plugin displaying "back to stream" link even if sopcast is not the selected streamer engine

    Windows installer:
    Ubuntu 11.10 deb installer:
    Manual installation package:

    Tomorrow i’ll release the stable version. I’ll wait until 12am (GMT +1) for bug report that can’t be resolved as a post-release patch-set. So, if anyone wants to test this, he has to do it now

    Some screenshots of how to use the new bookmarklet


    I get “invalid link” for all Hulu and Icefilms links with WiiMC. For some reason though, AllSP links work. Is there a setting I need to change?




    *** 0.5.5 beta3 (23/06/2012) ***
    – Fix for vlc 2.0
    – Rtmpdump bootstrap changed (need test)

    Download links in project home (link in my sign)


    Can someone please help me set this up?

    I’m using the latest beta of VLC shares and the latest version of VLC.
    I’m on Windows 7 64 bit
    I’m pretty sure I’m on the latest version of WiiMC also

    I can browse all the files on WiiMC but I get the error “Error loading file !” when I try to play anything

    Here is the debug log:

    Anyone feel like helping a noob out? It would be much appreciated.


    Did you use the auto-installer or do it manually? Is the file in your downloads you’re trying to play an actual file or a link to a file.Are none of the other sites working,or just some not looks as if you only tried 2 different videos.need more info on what works and what does not,and what exactly you are trying to do,or watch.


    I used the auto install, I’m trying to play a video from my PC. I tried a bunch after I posted that log and still get the same error. I tried turning off windows firewall still had the error. All the configurations are correct.
    I haven’t tried playing a plugin like hulu or anything.
    Any other info you need?


    Not knowing the type of video file or how your trying to play it,”streaming with vlc” or “Watch directly”.I can’t realy help you.The more info=the better your odds of finding the problem.Vlc,Vlc-shares,or a bad “File”.Does “The File” play in anything else.It should atleast play in the Vlc player,And yes,try your other plugins.This will help you find out if you even did the install right.The best plugins to check are,Youtube,Veetle,Hulu.
    Also you would be better off to use vlc-shares dashboard and add the folder contaning your videos to the “Shared folders” section of vlc-shares.Instead of going through a long file tree each time you try an play it.


    The files play fine in VLC, most are MKV files. I did add the folder to VLC dashboard, and I’m pretty sure I’m trying to stream it (I hit start VLC and then go to stream and then I get the error). I will try the plugins as soon as I get home and report back.


    OK,This helps alot.Since you are trying to stream and you know they play in vlc itself,Then i would try using the stream option in the veetle plugin.Also youtube,only certian videos in youtube will give you this option.If still no stream then i would suspect the beta version you are using is faulty.I also had problems with the beta3,so i reverted back to beta2.
    It looks like beta2 is no longer a download option.If you would like to test the beta2 version then PM me your email and i can send you the zip file.You should just have to unzip the file and replace your vlc-shares folder with the 1 i send.Then just setup the dashboard again.
    Otherwise i sugest a complete uninstall and reinstall vlc-shares/easyphp v5.4

    I’m pretty sure the change from vlc-shares v5.5b2 to 5.5b3 was in the streaming code directly.This adds to me thinking it is faulty.


    Sent you a PM with my email,

    also does it matter that I’m using VLC 2? What version are you using?

    Right now I’m doing a complete uninstall and reinstall to see if that will fix it.


    Well reinstall didn’t fix it still getting the Error, I tried the Veetle, Youtube and Hulu Plugins and they all got the same error.


    Well it seem that direct play works at least on youtube, so yeah I’m thinking the streaming code is broken.

Viewing 15 posts - 196 through 210 (of 220 total)
  • The forum ‘VLC Shares’ is closed to new topics and replies.


Lost Password